Новая Школа - онлайн-школа подготовки к ЕГЭ
При поддержке
  • Тренажёр заданий ЕГЭ
  • Информатика
  • Реальные варианты
  • Реальный вариант ЕГЭ 2020 (основная волна)
  • Реальный вариант ЕГЭ 2020 (основная волна) - Информатика

    Найдите значение выражения 7F16 – 7A16. Ответ укажите в десятичной системе счисления.

    Ответ

    В фрагменте базы данных представлены сведения о родственных отношениях. На основании имеющихся данных найдите минимальную разницу между годами рождения двух родных сестёр.

    Ответ

    Для кодирования некоторой последовательности, состоящей только из букв А, Б, В, Г, Д, решили использовать неравномерный двоичный код, удовлетворяющий условию Фано. Для букв А, Б, В использовали соответственно кодовые слова 1, 00, 0100. Укажите минимальную возможную суммарную длину для букв Г и Д, если известно, что код должен допускать однозначное декодирование.

     

    Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.

    Ответ

    На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число следующим образом.

    1)  Строится двоичная запись числа N.

    2)  К этой записи дописывается справа два нуля, если число четное, или две единицы в противном случае

    Укажите максимальное число N, после обработки которого с помощью этого алгоритма получается число менее 94. В ответе это число запишите в десятичной системе.

    Ответ

    В ячейки диапазонов C1:F6 и B2:B6 электронной таблицы записаны числа, как показано на рисунке.

      A B C D E F
    1     10 20 30 40
    2   1 11 21 31 41
    3   2 12 22 32 42
    4   3 13 23 33 43
    5   4 14 24 34 44
    6   5 15 25 35 45

    В ячейке B1 записали формулу =$F1+D$4. После этого ячейку B1 скопировали в ячейку C6. Какое число будет показано в ячейке C6?

    Примечание: знак $ используется для обозначения абсолютной адресации.

    Ответ

    Запишите число, которое будет напечатано в результате выполнения следующей программы.

    s = 190
    n = 0
    while s – n > 0:
        s = s – 5
        n = n + 15
    print(s)

    Ответ

    Дан целочисленный массив из 30 элементов. Элементы массива могут принимать положительные целые значения до 10 000 включительно. Опишите на одном из языков программирования алгоритм, который находит сумму четных элементов массива, больших 150, а затем меняет все такие элементы массива на полученную сумму.

    В качестве результата программа должна вывести измененный массив, по одному элементу в каждой строке.

    # допускается также 
    #использование #целочисленных
    # переменных m, k
    a = []
    N = 30
    for i in range(0, N):
        a.append(int(input()))
    …

    Ответ

    На вход программы поступает последовательность из N целых положительных чисел. Рассматриваются все пары различных элементов последовательности (элементы пары не обязаны стоять в последовательности рядом, порядок элементов в паре не важен). Необходимо вывести пару элементов, разность которых четна, а сумма максимальна. При этом по крайней мере одно число в паре делится на 31. Если таких пар несколько, то можно вывести любую из них. Если найти такую пару невозможно, то нужно вывести два нуля.

    Описание входных и выходных данных

    В первой строке входных данных задаётся количество чисел N (1 ≤ N ≤ 1000). В каждой из последующих N строк записано одно целое положительное число, не превышающее 10 000. В качестве результата программа должна напечатать два числа.

    Требуется написать эффективную по времени и по памяти программу для решения описанной задачи. Программа считается эффективной по времени, если при увеличении количества исходных чисел N в k раз время работы программы увеличивается не более чем в k раз. Программа считается эффективной по памяти, если память, необходимая для хранения всех переменных программы, не превышает 1 Кбайт и не увеличивается с ростом N.

    Максимальная оценка за правильную (не содержащую синтаксических ошибок и дающую правильный ответ при любых допустимых входных данных) программу, эффективную по времени и по памяти,  — 4 балла. Максимальная оценка за правильную программу, эффективную только по времени  — 3 балла. Максимальная оценка за правильную программу, не удовлетворяющую требованиям эффективности,  — 2 балла. Вы можете сдать одну программу или две программы решения задачи (например, одна из программ может быть менее эффективна). Если Вы сдадите две программы, то каждая из них будет оцениваться независимо от другой, итоговой станет бо́льшая из двух оценок.

    Перед текстом программы обязательно кратко опишите алгоритм решения. Укажите используемый язык программирования и его версию.

    Ответ

    На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.

    Сколько существует различных путей из города А в город М, проходящих через город Ж?

    Ответ

    Логическая функция F задаётся выражением (x ∧ ¬y) ∨ (y ≡ z) ∨ w.

    Дан частично заполненный фрагмент, содержащий неповторяющиеся строки таблицы истинности функции F.

    Определите, какому столбцу таблицы истинности соответствует каждая из переменных x, y, z, w.

     

    Переменная 1 Переменная 2 Переменная 3 Переменная 4 Функция
    ??? ??? ??? ??? F
          1 0
    1       0
    1 1     0

     

    В ответе напишите буквы x, y, z, w в том порядке, в котором идут соответствующие им столбцы (сначала  — буква, соответствующая первому столбцу; затем  — буква, соответствующая второму столбцу, и т. д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

    Ответ

    На снимок размером 1200 на 1024 пикселей в памяти выделено не более 1000 Кбайт. Найдите максимально возможное количество цветов в палитре изображения.

    Ответ

    Найдите количество пятизначных восьмеричных чисел, в которых все цифры различны и никакие две четные или нечетные не стоят рядом.

    Ответ

    Запишите подряд без пробелов и разделителей все числа, которые будут напечатаны на экране при выполнении вызова F(7). Числа должны быть записаны в том же порядке, в котором они выводятся на экран.

    def F(n):
        if n > 0:
            print(n)
            F(n // 3)
            F(n − 2)
     

    Ответ

    При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 9 символов и содержащий только заглавные буквы латинского 26-символьного алфавита. В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей. Для хранения сведений о 15 пользователях потребовалось 300 байт.

    Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число  — количество байт.

    Ответ

    В терминологии сетей TCP/IP маска сети  — это двоичное число, меньшее 232; в маске сначала (в старших разрядах) стоят единицы, а затем с некоторого места нули. Маска определяет, какая часть IP-адреса узла сети относится к адресу сети, а какая  — к адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес  — в виде четырёх байт, причём каждый байт записывается в виде десятичного числа. Адрес сети получается в результате применения поразрядной конъюнкции к заданному IP-адресу узла и маске.

    Например, если IP-адрес узла равен 131.32.255.131, а маска равна 255.255.240.0, то адрес сети равен 131.32.240.0.

    Для узла с IP-адресом 220.128.112.88 адрес сети равен 220.128.112.80. Чему равно значение последнего байта маски? Ответ запишите в виде десятичного числа.

    Ответ

    Дана программа для Редактора:

    НАЧАЛО

    ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>3)

        ЕСЛИ нашлось (>1)

        ТО заменить (>1, 22>)

        КОНЕЦ ЕСЛИ

        ЕСЛИ нашлось (>2)

        ТО заменить (>2, 2>)

        КОНЕЦ ЕСЛИ

        ЕСЛИ нашлось (>3)

        ТО заменить (>3, 1>)

        КОНЕЦ ЕСЛИ

    КОНЕЦ ПОКА

    КОНЕЦ

     

    На вход приведённой ниже программе поступает строка, начинающаяся с символа «>», а затем содержащая 26 цифр 1, 10 цифр 2 и 14 цифр 3, расположенных в произвольном порядке.

    Определите сумму числовых значений цифр строки, получившейся в результате выполнения программы. Так, например, если результат работы программы представлял бы собой строку, состоящую из 50 цифр 4, то верным ответом было бы число 200.

    Ответ

    На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Какова длина самого длинного пути из города А в город М? Длиной пути считать количество дорог, составляющих этот путь.

    Ответ

    Значение арифметического выражения: 1618 · 410 − 46 − 16  — записали в системе счисления с основанием 4. Сколько цифр «3» содержится в этой записи?

    Ответ

    В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И»  — символ «&».

    В таблице приведены запросы и количество страниц, которые нашел поисковый сервер по этим запросам в некотором сегменте Интернета:

    Запрос Количество

    страниц

    (тыс.)

    Руда 64
    Железо 41
    Витамины 36
    Руда | Железо | Витамины 105
    Железо & Витамины 27
    Руда & Витамины 0

    Сколько страниц (в тысячах) будет найдено по запросу Железо & Руда?

    Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.

    Ответ

    Для какого наибольшего целого положительного числа А выражение

     

     

    (x + 3y > A) ∨ (y < 30) ∨ (x < 30)

     

    тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?

    Ответ

    В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 0, 7, 1, 3, 2, 14, 5, 9, 11, 0, 7, т. е. A[0]=0, A[1]=7 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы

    s = 0
    n = 2
    for i in range(11):
        if A[i] < A[n]:
            s += A[i]
        else:
            A[n] = A[i]

    Ответ

    Ниже приведён алгоритм. Укажите наибольшее число x, при вводе которого алгоритм напечатает сначала 10, потом 3.

    x = int(input())
     L = 0
     M = 0
     while x > 0: 
         M = M + 1 
         if x % 2 == 0: 
            L = L + (x % 8) 
         x = x // 8
     print(L)
     print(M)

    Ответ

    Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма.

    def F(x):
    return(abs(abs(x−3)+abs(x+4)−9)+6)
     
    a = −20; b = 20
    M = a; R = F(a)
    for t in range(a,b+1):
        if F(t) <= R:
            M = t; R = F(t)
    print(M+R)
     

    Ответ

    Исполнитель преобразует число на экране. У исполнителя есть три команды, которым присвоены номера:

    1.  Прибавить 1

    2.  Прибавить 2

    3.  Умножить на 2

    Сколько существует программ, для которых при исходном числе 4 результатом является число 13, и при этом траектория вычислений содержит число 11?

    Ответ

    Сколько наборов логических переменных удовлетворяют условиям:

     

    ((xi ∧ yj) → (xi ∧ yj+1)) ∧ ((xi ∧ yj)→(xi+1 ∧ yj)) = 1

     

    для всех i < 6, j < 7.

    Ответ

    На вход программы поступают 4 положительных целых числа, не превышающие 1000, среди которых могут быть одинаковые. Нужно написать программу, которая выводит количество четных чисел и максимальное из них. Если среди входных данных нет чётных чисел, программа должна вывести слово 'NO'. Для решения этой задачи

    ученик написал такую программу:

    n = 4
    count = 0
    maximum = 1000
    for i in range (1, n+1):
        x = int(input())
        if x % 2 == 0:
            count += 1
            if x > maximum:
                maximum = i
    if count > 0:
        print (count)
        print (maximum)
    else:
        print ("NO")

    Последовательно выполните следующее.

    1.  Напишите, что выведет эта программа при вводе чисел 2 15 44 15.

    2.  Приведите пример такой последовательности, что, несмотря на ошибки, программа выдаст верный ответ.

    3.  Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки: выпишите строку, в которой сделана ошибка, и приведите правильный вариант строки.

    Ответ

    Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит табличка, на которой написано два числа. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок заменить любое из этих чисел на их

    сумму. Игра завершается в тот момент, когда сумма двух чисел становится не менее 28. Победителем считается игрок, сделавший последний ход, то есть первым получивший такую позицию, что сумма чисел будет 28 или больше.

    1.  Назовите максимальное значение S, при котором Петя не может выиграть первым ходом из позиции (7, S)

    2.  Кто имеет выигрышную стратегию из позиции (6,7)? Опишите эту стратегию.

    3.  Кто имеет выигрышную стратегию из позиции (2,3)? Опишите эту стратегию.

    Ответ

    Бесплатно
    Приложение ЕГЭ Тренажёр

    Скачивай мобильное приложение на iPhone или Android и тренируйся в любое время и в любом месте!

    Результаты тренировки
    Решено заданий 0
    Выполнено верно 0
    Выполнено частично верно 0
    Ошибки 0