Новая Школа - онлайн-школа подготовки к ЕГЭ
При поддержке
  • Тренажёр заданий ЕГЭ
  • Информатика
  • Реальные варианты
  • Реальный вариант ЕГЭ 2021 (основная волна)
  • Реальный вариант ЕГЭ 2021 (основная волна) - Информатика

    На вход программы поступает последовательность из целых положительных чисел. Необходимо выбрать такую подпоследовательность подряд идущих чисел, чтобы их сумма была максимальной и делилась на 89, а также её длину. Если таких подпоследовательностей несколько, выбрать такую, у которой длина меньше.

    Входные данные.

    Даны два входных файла (файл A и файл B), каждый из которых содержит в первой строке количество чисел N (2 ≤ N ≤ 68000). В каждой из последующих N строк записано одно целое положительное число, не превышающее 10000. Программа должна вывести длину найденной последовательности.

    Пример входного файла:

    8

    2

    3

    4

    93

    42

    34

    5

    95

    Для делителя 50 при указанных входных данных значением искомой суммы должно быть число 100 (3 + 4 + 93 или 5 + 95). Следовательно, ответ на задачу  — 2. В ответе укажите два числа: сначала значение искомой длины для файла A, затем для файла B.

    27-A.txt

    27-B.txt

    Ответ

    Даны фрагменты двух таблиц из базы данных. Каждая строка таблицы 2 содержит информацию о ребёнке и об одном из его родителей. Информация представлена значением поля ID в соответствующей строке таблицы 1. На основании имеющихся данных определите, сколько людей родилось в том же городе, что и один из их внуков или одна из их внучек?

    Ответ

    Для кодирования некоторой последовательности используют следующую кодировочную таблицу:

     

     

     

     

     

     

     

    Буква Кодовое слово
    А 00
    Б 1001
    В 1010
    Г 110
    Д 0101

     

     

     

     

     

     

     

    Буква Кодовое слово
    Е  
    Ж 011
    З 111
    И 0100
    К 1000

     

    Укажите код минимальной длины для буквы Е, такой что будет соблюдаться условие Фано. Если таких кодов несколько, укажите код с минимальным числовым значением.

     

    Ответ

    Какое максимальное значение переменной s, подаваемое на вход программе, для которого в результате работы программы на экран будет выведено значение 64? 

    n = 1024
    s = int(input())
    while s >= 5:
        s = s - 5
        n = n // 2
    print(n)

    Ответ

    Изображение размером 315 × 3072 пикселей сохраняется в памяти компьютера. Для его хранения выделяется не более 735 Кбайт без учёта заголовка файла. Все пиксели кодируются одинаковым количеством бит и записываются в файл один за другим. Какое максимальное количество цветов можно использовать в изображении? В ответе запишите только число.

    Ответ

    Дана программа для редактора:

     

    НАЧАЛО

        ПОКА нашлось (111) или нашлось (88888)

            ЕСЛИ нашлось (111)

                ТО заменить (111, 88)

                ИНАЧЕ заменить (88888, 8)

            КОНЕЦ ЕСЛИ

        КОНЕЦ ПОКА

    КОНЕЦ

     

    На вход программе подана строка из 100 единиц. Какая строка будет получена исполнителем после выполнения данного алгоритма?

    Ответ

    На рисунке  — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из города А в город М, проходящих через Г?

    Ответ

    На рисунке справа схема дорог Н-⁠ского района изображена в виде графа, в таблице содержатся сведения о длинах этих дорог (в километрах). Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. В таблице в левом столбце указаны номера пунктов, откуда совершается движение, в первой строке  — куда. Найдите сумму длин дорог из пункта Г в пункт Е и из пункта Д в З.

      П1 П2 П3 П4 П5 П6 П7
    П1           12 7
    П2         10 11 9
    П3       5 6 3  
    П4     5   15    
    П5   10 6 15      
    П6 12 11 3        
    П7 7 9          

    Ответ

    Логическая функция F задаётся выражением (¬a ∧ ¬b) ∨ (b ≡ c) ∨ d. На рисунке приведён частично заполненный фрагмент таблицы истинности функции F, содержащий неповторяющиеся строки. Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных a, b, c, d.

    Переменная 1 Переменная 2 Переменная 3 Переменная 4 Функция
        1   0
    1 0   1 0
    0 0 1 1 0

     

    В ответе напишите буквы a, b, c, d в том порядке, в котором идут соответствующие им столбцы (сначала  — буква, соответствующая первому столбцу; затем  — буква, соответствующая второму столбцу, и т. д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

    Ответ

    Автомат обрабатывает натуральное число N по следующему алгоритму.

    1.  Строится двоичная запись числа N.

    2.  Если N четное, то в конец полученной записи (справа) дописывается 0, в начало  — 1; если N  — нечётное в конец и начало дописывается по две единицы.

    3.  Результат переводится в десятичную систему и выводится на экран.

    Пример. Дано число N  =  13. Алгоритм работает следующим образом:

    1.  Двоичная запись числа N: 1101.

    2.  Число нечетное, следовательно, по две единицы по краям  — 11110111.

    3.  На экран выводится число 247.

     

    Укажите наименьшее число, большее 52, которое может является результатом работы автомата.

    Ответ

    Ученица составляет 5-буквенные слова из букв ГЕПАРД. При этом в каждом слове ровно одна буква Г, слово не может начинаться на букву А и заканчиваться буквой Е. Какое количество слов может составить ученица?

    Ответ

    Электронная таблица содержит результаты метеорологических наблюдений. Найдите разницу между максимальной температурой в июле и минимальной температурой в октябре. В ответе запишите только целую часть полученного результата.

    9.xls

    Ответ

    Определите, сколько раз в тексте поэмы Н. А. Некрасова «Кому на Руси жить хорошо» встречается слово «Мой» написанное с прописной буквы. Другие формы слова «Мой», такие как «Мои», «Моего» и прочие учитывать не следует.

    10.doc

    Ответ

    При регистрации в компьютерной системе каждому пользователю выдается идентификатор из 101 символа, каждый из которых может быть десятичной цифрой или одним из 4090 символов из специального набора. Каждый символ кодируется с помощью одинакового и минимального количества бит. Идентификатор же записывается в памяти с помощью минимально возможного целого количества байт.

    Сколько килобайт потребуется для хранения идентификаторов 2048 пользователей?

    Ответ

    Значение выражения 4 · 6259 − 2515 + 2 · 511 − 7 записали в системе счисления с основанием 5. Сколько цифр 4 в получившейся записи?

    Ответ

    Для какого наибольшего целого неотрицательного числа A выражение

     

    (2x + y ≠ 70) ∨ (x < y) ∨ (A < x)

     

    тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

    Ответ

    Алгоритм вычисления значения функции F(n), где n  — целое неотрицательное число, задан следующими соотношениями:

     

    F(n) = 0, при n ≤ 1;

    F(n) = F(n − 1) + 3n2, если n > 1 и при этом нечётно;

    F(n) = n / 2 + F(n − 1) + 2, если n > 1 и при этом чётно.

     

    Чему равно значение функции F(49)? В ответе запишите только целое число.

    Ответ

    Рассматривается множество целых чисел, принадлежащих числовому отрезку [12972; 89322], которые при делении на 13 дают остаток 7, при этом не делятся ни на 7, ни на 11. Найдите наибольшее из таких чисел и их количество. В ответе укажите два числа друг за другом без разделительных знаков  — сначала количество найденных чисел, затем наибольшее найденное число.

    Ответ

    Квадрат разлинован на N × N клеток (1 < N < 17). Исполнитель Робот может перемещаться по клеткам, выполняя за одно перемещение одну из двух команд: вправо или вниз. По команде вправо Робот перемещается в соседнюю правую клетку, по команде вниз  — в соседнюю нижнюю. При попытке выхода за границу квадрата Робот разрушается, при столкновении со стеной робот разрушается. В каждой клетке записано число  — количество монет, которое добавляется к счету робота. Определите максимальное и минимальное значения счёта, которые может получить робот после окончания работы в лабиринте. Начальным значением счёта является значение стартовой клетки. Робот движется из левой верхней в правую нижнюю клетки.

    Исходные данные записаны в электронной таблице. В ответ запишите два числа друг за другом без разделительных знаков  — сначала максимальное значение счёта, затем минимальное.

    18 (9).xlsx

    Ответ

    Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один или четыре камня или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 16, 19 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней.

    Игра завершается в тот момент, когда количество камней в куче становится не менее 40. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 40 или больше камней.

    В начальный момент в куче было S камней, 1 ≤ S ≤ 39.

    Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока  — значит, описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника.

    Известно, что Петя не может выиграть своим первым ходом, однако после любого хода Пети Ваня может выиграть. При каком значении S это возможно?

    Ответ

    Известно, что Петя имеет выигрышную стратегию в два хода, при этом Петя не может выиграть первым ходом. Укажите два значения S, при которых это возможно. Значения укажите в порядке возрастания без разделительных знаков.

    Ответ

    Известно, что Ваня имеет выигрышную стратегию за один или два хода, при этом не имеет выигрышной стратегии в один ход. Найдите минимальное значение S, при котором это возможно.

    Ответ

    Ниже записана программа. Получив на вход число x, эта программа печатает два числа a и b. При каком наименьшем значении x после выполнения программы на экран будет выведено два числа 10, а затем 6.

    x = int(input())
    a, b = 0, 0
    while x > 0:
        c = x % 10
        a = a + c
        if b < c:
            b = c
        x = x // 10
    print(a)
    print(b)

    Ответ

    Исполнитель преобразует число на экране. У исполнителя есть три команды, которым присвоены номера:

    1. Прибавить 1

    2.  Прибавить 2

    3.  Умножить на 3

    Первая команда увеличивает число на 1, вторая  — на 2, третья  — втрое. Программа для исполнителя  — это последовательность команд. Сколько существует таких программ, которые исходное число 2 преобразуют в число 19 и при этом траектория вычислений программы проходит через 9 и не проходит через 12?

    Ответ

    Текстовый файл состоит не более, чем из 107 строчных букв английского алфавита. Найдите максимальную длину подстроки, в которой символы «a» и «d» не стоят рядом.

    Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.

    24 (6).txt

    Ответ

    Найдите 5 чисел больших 500000, таких, что среди их делителей есть число, оканчивающееся на 8, при этом этот делитель не равен 8 и самому числу. В качестве ответа приведите 5 наименьших чисел, соответствующих условию.

    Формат вывода: для каждого из 5 таких найденных чисел в отдельной строке сначала выводится само число, затем минимальный делитель, оканчивающийся на 8, не равный 8 и самому числу.

    Ответ

    Организация купила для своих сотрудников все места в нескольких подряд идущих рядах на концертной площадке. Известно, какие места уже распределены между сотрудниками. Найдите ряд с наибольшим номером, в котором есть два соседних места, таких что слева и справа от них в том же ряду места уже распределены (заняты). Гарантируется, что есть хотя бы один ряд, удовлетворяющий условию. В ответе запишите два целых числа: номер ряда и наименьший номер места из найденных в этом ряду подходящих пар.

    Входные данные.

    В первой строке входного файла находится одно число: N  — количество занятых мест (натуральное число, не превышающее 10 000). В следующих N строках находятся пары чисел: ряд и место выкупленного билета (числа не превышают 100 000).

    В ответе запишите два целых числа: сначала максимальный номер ряда, где нашлись обозначенные в задаче места и минимальный номер места.

    Пример входного файла:

    6

    50 12

    50 15

    60 157

    60 160

    60 22

    60 25

    Для данного примера ответом будет являться пара чисел 60 и 23.

    26 (3).txt

    Ответ

    Бесплатно
    Приложение ЕГЭ Тренажёр

    Скачивай мобильное приложение на iPhone или Android и тренируйся в любое время и в любом месте!

    Результаты тренировки
    Решено заданий 0
    Выполнено верно 0
    Выполнено частично верно 0
    Ошибки 0