Новая Школа - онлайн-школа подготовки к ЕГЭ
При поддержке
  • Тренажёр заданий ЕГЭ
  • Информатика
  • Реальные варианты
  • Реальный вариант ЕГЭ 2022 (основная волна)
  • Реальный вариант ЕГЭ 2022 (основная волна) - Информатика

    Определите, при каком наименьшем введённом значении переменной s программа выведет число 32.

    s = int(input())
    s = (s − 21) // 10
    n = 1
    while s > 0:
        n = n * 2
        s = s - n
    print(n)

    Ответ

    Для хранения сжатого произвольного растрового изображения размером 192 на 960 пикселей отведено 90 Кбайт памяти без учёта размера заголовка файла. При сжатии объём файла уменьшается на 35%. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?

    Ответ

    Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 84 идущих подряд цифр 8? В ответе запишите полученную строку.

    НАЧАЛО

        ПОКА нашлось (1111) ИЛИ нашлось (8888)

            ЕСЛИ нашлось (1111)

                ТО заменить (1111, 8)

                ИНАЧЕ заменить (8888, 11)

            КОНЕЦ ЕСЛИ

        КОНЕЦ ПОКА

    КОНЕЦ

    Ответ

    На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.

    Какова длина самого длинного пути из города А в город М? Длиной пути считать количество дорог, составляющих этот путь.

    Ответ

    На каждом 3-м километре кольцевой автодороги с двусторонним движением установлены контейнеры для мусора. Длина кольцевой автодороги равна 3N километров. Нулевой километр и 3N-й километр автодороги находятся в одной точке. Известно количество мусора, которое накапливается ежедневно в каждом из контейнеров. Из каждого пункта мусор вывозит отдельный мусоровоз. Стоимость доставки мусора вычисляется как произведение количества мусора на расстояние от пункта до центра переработки. Центр переработки отходов открыли в одном из пунктов сбора мусора таким образом, чтобы общая стоимость доставки мусора из всех пунктов в этот центр была минимальной.

    Определите минимальные расходы на доставку мусора в центр переработки отходов.

    Входные данные

    Дано два входных файла (файл A и файл B), каждый из которых в первой строке содержит число N (1 ≤ N ≤ 10 000 000)  — количество пунктов сбора мусора на кольцевой автодороге. В каждой из следующих N строк находится число  — количество мусора в контейнере (все числа натуральные, количество мусора в каждом пункте не превышает 1000). Числа указаны в порядке расположения контейнеров на автомагистрали, начиная с первого километра.

    В ответе укажите два числа: сначала значение искомой величины для файла А, затем  — для файла B.

    Типовой пример организации данных во входном файле

    6

    8

    20

    5

    13

    7

    19

    При таких исходных данных, если контейнеры установлены на каждом километре автодороги, необходимо открыть центр переработки в пункте 6. В этом случае сумма транспортных затрат составит: 1 · 7 + 0 · 19 + 1 · 8 + 2 · 20 + 3 · 5 + 2 · 13.

    107_27_A.txt

    107_27_B.txt

    Ответ

    На рисунке схема дорог Н-⁠ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова сумма протяжённостей дорог из пункта D в пункт B и из пункта A в пункт E.

    В ответе запишите целое число. 

      П1 П2 П3 П4 П5 П6 П7
    П1       5 21    
    П2     13 3 30    
    П3   13     53 2  
    П4 5 3         8
    П5 21 30 53        
    П6     2       39
    П7       8   39  

    Ответ

    Миша заполнял таблицу истинности логической функции F

    ¬ (x → w) ∨ (y ≡ z) ∨ y,

     

    но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

    Переменная 1 Переменная 2 Переменная 3 Переменная 4 Функция
      1   0 0
      0 1   0
        0   0

     

    Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

    Ответ

    Используя информацию из приведённой базы данных, определите, на сколько увеличилось количество упаковок соды пищевой, имеющихся в наличии в магазинах Октябрьского района, за период с 1 по 8 июня включительно.

    В ответе запишите только число.

    107_3.xls

    Ответ

    По каналу связи передаются сообщения, содержащие только буквы из набора: А, Б, К, Р, Н. Для передачи используется двоичный код, удовлетворяющий условию Фано. Это условие обеспечивает возможность однозначной расшифровки закодированных сообщений. Кодовые слова для некоторых букв известны: К  — 01, Р  — 001. Для трёх оставшихся букв Б, Н и А кодовые слова неизвестны. Какое количество двоичных знаков потребуется для кодирования слова БАРАБАН, если известно, что оно закодировано минимально возможным количеством двоичных знаков?

    Ответ

    На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

    1.  Строится двоичная запись числа N.

    2.  Далее эта запись обрабатывается по следующему правилу:

    а)  если число чётное, то к двоичной записи числа слева дописывается 10;

    б)  если число нечётное, то к двоичной записи числа слева дописывается 1 и справа дописывается 01.

    Полученная таким образом запись является двоичной записью искомого числа R.

    Например, для исходного числа 410  =  1002 результатом будет являться число 2010  =  101002, а для исходного числа 510  =  1012 результатом будет являться число 5310  =  1101012.

     

    Укажите минимальное число N, после обработки которого с помощью этого алгоритма получается число R, большее, чем 441. В ответе запишите это число в десятичной системе счисления.

    Ответ

    Все пятибуквенные слова, в составе которых могут быть только буквы Б, А, Т, Ы, Р, записаны в алфавитном порядке и пронумерованы начиная с 1.

    Ниже приведено начало списка.

    1.  ААААА

    2.  ААААБ

    3.  ААААР

    4.  ААААТ

    5.  ААААЫ

    6.  АААБА

    …

    Под каким номером в списке идёт первое слово, которое не содержит ни одной буквы Ы и не содержит букв А, стоящих рядом?

    Ответ

    Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел.

    Определите количество строк таблицы, в которых квадрат суммы максимального и минимального чисел в строке больше суммы квадратов трёх оставшихся.

    107_9 (1).xlsx

    Ответ

    Текст романа Льва Николаевича Толстого «Анна Каренина» представлен в виде файла формата «.docx». Откройте его и определите, сколько раз встречается в тексте отдельное слово «душа» со строчной буквы.

    В ответе запишите только число.

    107_10.docx

    Ответ

    При регистрации в компьютерной системе каждому объекту присваивается идентификатор, состоящий из 234 символов и содержащий только десятичные цифры и символы из 1350-символьного специального алфавита. В базе данных для хранения каждого идентификатора отведено одинаковое и минимально возможное целое число байт. При этом используется посимвольное кодирование идентификаторов, все символы кодируются одинаковым и минимально возможным количеством бит.

    Определите объём памяти (в Кбайт), необходимый для хранения 65 536 идентификаторов. В ответе запишите только целое число  — количество Кбайт.

    Ответ

    Значение арифметического выражения

     

    7 · 5121912 + 6 · 641954 − 5 · 81991 − 4 · 81980 − 2022

     

    записали в системе счисления с основанием 8. Определите количество цифр 7 в записи этого числа.

    Ответ

    Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

    Для какого наименьшего натурального числа А формула

     

    (ДЕЛ(x, 3) → ¬ДЕЛ(x, 5)) ∨ (x + A ≥ 90)

     

    тождественно истинна (т. е. принимает значение 1) при любом натуральном значении переменной x?

    Ответ

    Алгоритм вычисления значения функции F(n), где n  — натуральное число, задан следующими соотношениями:

    F(n)  =  2 при n < 3;

    F(n)  =  F(n − 2) + F(n − 1) − n, если n > 2 и при этом n чётно,

    F(n) =F(n − 1) − F(n − 2) + 2 × n, если n > 2 и при этом n нечётно.

    Чему равно значение функции F(32)?

    Ответ

    В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых хотя бы одно число делится на минимальный элемент последовательности, кратный 21. Гарантируется, что такой элемент в последовательности есть. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

    107_17.txt

    Ответ

    Квадрат разлинован на N × N клеток (1 < N < 30). Исполнитель Робот может перемещаться по клеткам, выполняя за одно перемещение одну из двух команд: вправо или вниз. По команде вправо Робот перемещается в соседнюю правую клетку, по команде вниз  — в соседнюю нижнюю. Квадрат ограничен внешними стенами. Между соседними клетками квадрата также могут быть внутренние стены. Сквозь стену Робот пройти не может.

    Перед каждым запуском Робота в каждой клетке квадрата лежит монета достоинством от 1 до 100. Посетив клетку, Робот забирает монету с собой; это также относится к начальной и конечной клеткам маршрута Робота.

    Определите максимальную и минимальную денежные суммы, которые может собрать Робот, пройдя из левой верхней клетки в правую нижнюю. В ответе укажите два числа  — сначала максимальную сумму, затем минимальную.

    107_18.xlsx

    Ответ

    Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в два раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

    Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 231. Победителем считается игрок, сделавший последний ход, т. е. первым получивший такую позицию, при которой в кучах будет 231 или больше камней.

    В начальный момент в первой куче было 17 камней, во второй куче  — S камней; 1 ≤ S ≤ 213.

    Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

    Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, когда такая ситуация возможна.

    Ответ

    Найдите два наименьших значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

    — Петя не может выиграть за один ход;

    — Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

    Найденные значения запишите в ответе в порядке возрастания без разделительных знаков.

    Ответ

    Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

    Найдите минимальное значение S, при котором одновременно выполняются два условия:

    — у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

    — у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

    Ответ

    Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 12, а потом 19.

     
     x = int(input())
     Q = 8
     P = 10
     K1 = 0
     K2 = 0
     while x <= 100:
        K1 = K1 + 1
        x = x + P
     while x >= Q:
        K2 = K2 + 1
        x = x − Q
     L= x + K1
     M = x + K2
     print(L)
     print(M)

    Ответ

    Исполнитель преобразует число на экране.

    У исполнителя есть две команды, которым присвоены номера:

    1.  Прибавь 2

    2.  Умножь на 2

    Первая из них увеличивает число на экране на 2, вторая увеличивает число на экране в два раза.

    Программа для исполнителя  — это последовательность команд.

    Сколько существует программ, для которых при исходном числе 1 результатом является число 52, и при этом траектория вычислений содержит число 18?

    Траектория вычислений программы  — это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 3 траектория будет состоять из чисел 5, 10, 12.

    Ответ

    Текстовый файл состоит из символов A, B и C.

    Определите максимальное количество идущих подряд пар символов AB или CB в прилагаемом файле.

    Искомая подпоследовательность должна состоять только из пар AB, или только из пар CB, или только из пар AB и CB в произвольном порядке следования этих пар.

    Для выполнения этого задания следует написать программу.

    107_24.txt

    Ответ

    Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

    — символ «?» означает ровно одну произвольную цифру;

    — символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать и пустую последовательность.

    Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

    Среди натуральных чисел, не превышающих 109, найдите все числа, соответствующие маске 12345?7?8, делящиеся на число 23 без остатка.

    В ответе запишите в первом столбце таблицы все найденные числа в порядке возрастания, а во втором столбце  — соответствующие им результаты деления этих чисел на 23.

    Ответ

    В лесничестве саженцы сосны высадили параллельными рядами, которые пронумерованы идущими подряд натуральными числами. Растения в каждом ряду пронумерованы натуральными числами начиная с единицы.

    По данным аэрофотосъёмки известно, в каких рядах и на каких местах растения не прижились. Найдите ряд с наибольшим номером, в котором есть ровно 13 идущих подряд свободных мест для посадки новых сосен, таких, что непосредственно слева и справа от них в том же ряду растут сосны. Гарантируется, что есть хотя бы один ряд, удовлетворяющий этому условию. В ответе запишите два целых числа: наибольший номер ряда и наименьший номер места для посадки из числа найденных в этом ряду подходящих последовательностей из 13 свободных мест.

    Входные данные.

    В первой строке входного файла находится число N  — количество прижившихся саженцев сосны (натуральное число, не превышающее 20 000). Каждая из следующих N строк содержит два натуральных числа, не превышающих 100 000: номер ряда и номер места в этом ряду, на котором растёт деревце.

    Выходные данные

    Два целых неотрицательных числа: наибольший номер ряда и наименьший номер места в выбранной последовательности из 13 мест, подходящих для посадки новых сосен.

    Типовой пример организации входных данных

    7

    40 3

    40 7

    60 33

    50 125

    50 129

    50 68

    50 72

    Для приведённого примера, при условии, что необходимо 3 свободных места, ответом является пара чисел: 50; 69.

    107_26 (1).txt

    Ответ

    Бесплатно
    Приложение ЕГЭ Тренажёр

    Скачивай мобильное приложение на iPhone или Android и тренируйся в любое время и в любом месте!

    Результаты тренировки
    Решено заданий 0
    Выполнено верно 0
    Выполнено частично верно 0
    Ошибки 0