Новая Школа - онлайн-школа подготовки к ЕГЭ
При поддержке
  • Тренажёр заданий ЕГЭ
  • Информатика
  • Демоверсии от ФИПИ
  • Демоверсия ЕГЭ 2022
  • Демоверсия ЕГЭ 2022 - Информатика

    Определите, при каком наибольшем введённом значении переменной s программа выведет число 64.

    s = int(input())
    s = s // 10
    n = 1
    while s < 51:
        s = s + 5
        n = n * 2
    print(n)

    Ответ

    Для хранения произвольного растрового изображения размером 128×320 пикселей отведено 20 Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?

    Ответ

     

    Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 70 идущих подряд цифр 8? В ответе запишите полученную строку.

    НАЧАЛО

        ПОКА нашлось (2222) ИЛИ нашлось (8888)

            ЕСЛИ нашлось (2222)

                ТО заменить (2222, 88)

                ИНАЧЕ заменить (8888, 22)

            КОНЕЦ ЕСЛИ

        КОНЕЦ ПОКА

    КОНЕЦ

    Ответ

    На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.

    Сколько существует различных путей из города А в город М, проходящих через город В?

    Ответ

    Дана последовательность из N натуральных чисел. Рассматриваются все её непрерывные подпоследовательности, такие что сумма элементов каждой из них кратна k  =  43. Найдите среди них подпоследовательность с максимальной суммой, определите её длину. Если таких подпоследовательностей найдено несколько, в ответе укажите количество элементов самой короткой из них.

    Входные данные

    Даны два входных файла (файл A и файл B), каждый из которых содержит в первой строке количество чисел N (1 ≤ N ≤ 10 000 000). Каждая из следующих N строк содержит одно натуральное число, не превышающее 10 000.

    Пример организации исходных данных во входном файле:

    14

    1

    2

    1

    4

    93

    8

    5

    95

    6

    4

    3

    2

    8

    6

     В ответе укажите два числа: сначала значение искомой длины для файла А, затем  — для файла B. Для приведенного примера ответ 7.

    27_A (1).txt

    27_B (1).txt

    Ответ

    На рисунке схема дорог N-⁠ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах). Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова сумма протяжённостей дорог из пункта Б в пункт В и из пункта Г в пункт Д. В ответе запишите целое число.

      П1 П2 П3 П4 П5 П6 П7
    П1   3     4    
    П2 3       12 13  
    П3       10 11    
    П4     10   9   7
    П5 4 12 11 9   8 6
    П6   13     8   5
                   
     
    Ответ

    Миша заполнял таблицу истинности логической функции F

    ¬ (y → (x ≡ w)) ∧ (z → x),

    но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

     

    Переменная 1 Переменная 2 Переменная 3 Переменная 4 Функция
      1 1   1
    0     0 1
      0 1 0 1

     

    Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

    В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т. д.). Буквы в ответе пишите подряд, никаких разделителей между буквами ставить

    не нужно.

    Ответ

    Используя информацию из приведённой базы данных, определите, на сколько увеличилось количество упаковок яиц диетических, имеющихся в наличии в магазинах Заречного района за период с 1 по 10 июня.

    В ответе запишите только число.

    3 (1).xlsx

    Ответ

    Для кодирования некоторой последовательности, состоящей из букв Л, М, Н, П, Р, решили использовать неравномерный двоичный код, удовлетворяющий условию, что никакое кодовое слово не является началом другого кодового слова. Это условие обеспечивает возможность однозначной расшифровки закодированных сообщений. Для букв Л, М, Н использовали соответственно кодовые слова 00, 01, 11. Для двух оставшихся букв П и Р  — кодовые слова неизвестны. Укажите кратчайшее возможное кодовое слово для буквы П, при котором код будет удовлетворять указанному условию. Если таких кодов несколько, укажите код с наименьшим числовым значением.

    Ответ

    На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

    1.  Строится двоичная запись числа N.

    2.  К этой записи дописываются справа ещё два разряда по следующему правилу:

    а)  складываются все цифры двоичной записи числа N, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001;

    б)  над этой записью производятся те же действия  — справа дописывается остаток от деления суммы цифр на 2.

    Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью результирующего числа R.

     

    Укажите такое наименьшее число N, для которого результат работы алгоритма больше числа 77. В ответе это число запишите в десятичной системе счисления.

    Ответ

    Все четырёхбуквенные слова, в составе которых могут быть только буквы Л, Е, М, У, Р, записаны в алфавитном порядке и пронумерованы, начиная с 1. Ниже приведено начало списка.

    1.  ЕЕЕЕ

    2.  ЕЕЕЛ

    3.  ЕЕЕМ

    4.  ЕЕЕР

    5.  ЕЕЕУ

    6.  ЕЕЛЕ

    …

    Под каким номером в списке идёт первое слово, которое начинается с буквы Л?

    Ответ

    Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа.

    Выясните, какое количество троек чисел может являться сторонами треугольника, то есть удовлетворяет неравенству треугольника. В ответе запишите только число.

    9 (1).xlsx

    Ответ

    С помощью текстового редактора определите, сколько раз, не считая сносок, встречается слово «долг» или «Долг» в тексте романа в стихах А. С. Пушкина «Евгений Онегин». Другие формы слова «долг», такие как «долги», «долгами» и т. д., учитывать не следует. В ответе укажите только число.

    10_demo2021.docx

    Ответ

    При регистрации в компьютерной системе каждому пользователю выдаётся идентификатор, состоящий из 15 символов и содержащий только символы из 8-символьного набора: А, В, C, D, Е, F, G, H. В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование идентификаторов, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно идентификатора, для каждого объекта в системе хранятся дополнительные сведения, для чего отведено 24 байт на один объект.

    Определите объём памяти (в байтах), необходимый для хранения сведений о 20 объектах. В ответе запишите только целое число  — количество байт.

    Ответ

    Значение арифметического выражения

     

    3 · 438 + 2 · 423 + 420 + 3 · 45 + 2 · 44 + 1

     

    записали в системе счисления с основанием 16. Сколько значащих нулей содержится в этой записи?

    Ответ

    На числовой прямой даны два отрезка: D  =  [17; 58] и C  =  [29; 80]. Укажите наименьшую возможную длину такого отрезка A, для которого логическое выражение

     

    (x ∈ D) → ((¬(x ∈ C)∧ ¬(x ∈ A)) → ¬(x ∈ D))

     

    истинно (т. е. принимает значение 1) при любом значении переменной х.

    Ответ

    Алгоритм вычисления значения функции F(n), где n  — натуральное число, задан следующими соотношениями:

    F(n)  =  1 при n  =  1;

    F(n)  =  n + F(n − 1), если n чётно,

    F(n)  =  2 × F(n − 2), если n > 1 и при этом n нечётно.

    Чему равно значение функции F(26)?

    Ответ

    В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от −10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых хотя бы одно число делится на 3, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности из пяти элементов: 6; 2; 9; –3; 6  — ответ: 4 11.

    17 (3).txt

    Ответ

    Квадрат разлинован на N × N клеток (1 < N < 30). Исполнитель Робот может перемещаться по клеткам, выполняя за одно перемещение одну из двух команд: вправо или вниз. По команде вправо Робот перемещается в соседнюю правую клетку, по команде вниз  — в соседнюю нижнюю. Квадрат ограничен внешними стенами. Между соседними клетками квадрата также могут быть внутренние стены. Сквозь стену Робот пройти не может. Перед каждым запуском Робота в каждой клетке квадрата лежит монета достоинством от 1 до 100. Посетив клетку, Робот забирает монету с собой; это также относится к начальной и конечной клеткам маршрута Робота.

    Определите максимальную и минимальную денежные суммы, которые может собрать Робот, пройдя из левой верхней клетки в правую нижнюю.

    В ответе укажите два числа  — сначала максимальную сумму, затем минимальную.

    18 (3).xlsx

    Ответ

    Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один камень или увеличить количество камней в куче в два раза. Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

    Игра завершается в тот момент, когда количество камней в куче становится не менее 29. Победителем считается игрок, сделавший последний ход, т. е. первым получивший кучу, в которой будет 29 или больше камней.

    В начальный момент в куче было S камней, 1 ≤ S ≤ 28.

    Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

    Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом.

    Ответ

    Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

    Найдите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

    — Петя не может выиграть за один ход;

    — Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

    Найденные значения запишите в ответе в порядке возрастания.

    Ответ

    Для игры, описанной в задании 19, найдите значение S, при котором одновременно выполняются два условия:

    — у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

    — у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

    Если найдено несколько значений S, в ответе запишите минимальное из них.

    Ответ

    Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 4, а потом 5. 

    x = int(input())
     Q = 9
     L = 0
     while x >= Q:
        L = L + 1
        x = x - Q
     M = x
     if M < L:
        M = L
        L = x
     print(L)
     print(M)

    Ответ

    Исполнитель преобразует число на экране.

    У исполнителя есть две команды, которым присвоены номера:

    1.  Прибавить 1

    2.  Умножить на 2

    Первая команда увеличивает число на экране на 1, вторая умножает его на 2. Программа для исполнителя  — это последовательность команд.

    Сколько существует программ, для которых при исходном числе 1 результатом является число 20 и при этом траектория вычислений содержит число 10?

    Траектория вычислений программы  — это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 7 траектория будет состоять из чисел 8, 16, 17.

    Ответ

    Текстовый файл состоит из символов P, Q, R и S.

    Определите максимальное количество идущих подряд символов в прилагаемом файле, среди которых нет идущих подряд символов P.

    24 (3).txt

    Ответ

    Пусть M  — сумма минимального и максимального натуральных делителей целого числа, не считая единицы и самого числа. Если таких делителей у числа нет, то значение M считается равным нулю.

    Напишите программу, которая перебирает целые числа, бо́льшие 700 000, в порядке возрастания и ищет среди них такие, для которых значение M оканчивается на 8. Выведите первые пять найденных чисел и соответствующие им значения M.

    Формат вывода: для каждого из пяти таких найденных чисел в отдельной строке сначала выводится само число, затем  — значение М.

    Строки выводятся в порядке возрастания найденных чисел.

    Ответ

    Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя.

    По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите максимальное число пользователей, чьи файлы можно сохранить в архиве, а также максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

    Входные данные.

    В первой строке входного файла находятся два числа: S  — размер свободного места на диске (натуральное число, не превышающее 10 000) и N  — количество пользователей (натуральное число, не превышающее 1000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

    Запишите в ответе два числа: сначала наибольшее число пользователей, чьи файлы могут быть помещены в архив, затем максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

    Пример входного файла:

    100 4

    80

    30

    50

    40

    При таких исходных данных можно сохранить файлы максимум двух пользователей. Возможные объёмы этих двух файлов 30 и 40, 30 и 50 или 40 и 50. Наибольший объём файла из перечисленных пар  — 50, поэтому ответ для приведённого примера:

    2 50

    26_demo.txt

    Ответ

    Бесплатно
    Приложение ЕГЭ Тренажёр

    Скачивай мобильное приложение на iPhone или Android и тренируйся в любое время и в любом месте!

    Результаты тренировки
    Решено заданий 0
    Выполнено верно 0
    Выполнено частично верно 0
    Ошибки 0