Новая Школа - онлайн-школа подготовки к ЕГЭ
При поддержке
  • Тренажёр заданий ЕГЭ
  • Информатика
  • Демоверсии от ФИПИ
  • Демоверсия ЕГЭ 2019
  • Демоверсия ЕГЭ 2019 - Информатика

    Сколько существует натуральных чисел x, для которых выполняется неравенство 100110112 < x < 100111112? В ответе укажите только количество чисел, сами числа писать не нужно.

    Ответ

    На рисунке схема дорог Н-⁠ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).

      П1 П2 П3 П4 П5 П6 П7
    П1       9     7
    П2       5   11  
    П3           12  
    П4 9 5     4 13 15
    П5       4   10 8
    П6   11 12 13 10    
    П7 7     15 8    
    Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова протяжённость дороги из пункта Д в пункт Е. В ответе запишите целое число  — так, как оно указано в таблице.
    Ответ

    Ниже представлены два фрагмента таблиц из базы данных о жителях микрорайона. Каждая строка таблицы 2 содержит информацию о ребёнке и об одном из его родителей. Информация представлена значением поля ID в соответствующей строке таблицы 1. Определите на основании приведённых данных, у скольких детей на момент их рождения отцам было больше 25 полных лет. При вычислении ответа учитывайте только информацию из приведённых фрагментов таблиц.

    Ответ

    На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

    1.  Строится двоичная запись числа N.

    2.  К этой записи дописываются справа ещё два разряда по следующему правилу:

    а)  складываются все цифры двоичной записи числа N, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001;

    б)  над этой записью производятся те же действия  — справа дописывается остаток от деления суммы её цифр на 2.

    Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью искомого числа R. Укажите минимальное число R, которое превышает число 97 и может являться результатом работы данного алгоритма. В ответе это число запишите в десятичной системе счисления.

    Ответ

    Дан фрагмент электронной таблицы. Из ячейки B3 в ячейку C2 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились. Каким стало числовое значение формулы в ячейке C2?

      А B C D E
    1 1 10 100 1000 10000
    2 2 20   2000 20000
    3 3 =A$2+D$3 300 3000 30000
    4 4 40 400 4000 40000

     

    Примечание: знак $ обозначает абсолютную адресацию.

    Ответ

    Запишите число, которое будет напечатано в результате выполнения следующей программы

    s = 0
    n = 1
    while s < 51:
        s = s + 11
        n = n * 2
    print(n)

    Ответ

    Дан целочисленный массив из 30 элементов. Элементы массива могут принимать натуральные значения от 1 до 10 000 включительно. Опишите на одном из языков программирования алгоритм, который находит минимум среди элементов массива, не делящихся нацело на 6, а затем заменяет каждый элемент, не делящийся нацело на 6, на число, равное найденному минимуму. Гарантируется, что хотя бы один такой элемент в массиве есть. В качестве результата необходимо вывести изменённый массив, каждый элемент выводится с новой строчки.

    Например, для исходного массива из шести элементов:

    14

    6

    11

    18

    9

    24

    программа должна вывести следующий массив:

    9

    6

    9

    18

    9

    24

    # допускается также
    # использовать две
    # целочисленные переменные j и k
    a = []
    n = 30
    for i in range(0, n):
        a.append(int(input()))
    ...

     

    В качестве ответа Вам необходимо привести фрагмент программы, который должен находиться на месте многоточия. Вы можете записать решение также на другом языке программирования (укажите название и используемую версию языка программирования, например Free Pascal 2.6). В этом случае Вы должны использовать те же самые исходные данные и переменные, какие были предложены в условии (например, в образце, записанном на Алгоритмическом языке).

    Ответ

    На вход программы поступает последовательность из n целых положительных чисел. Рассматриваются все пары элементов последовательности ai и aj, такие что i < j и ai > aj (первый элемент пары больше второго; i и j  — порядковые номера чисел в последовательности входных данных). Среди пар, удовлетворяющих этому условию, необходимо найти и напечатать пару с максимальной суммой элементов, которая делится на m  =  120. Если среди найденных пар максимальную сумму имеют несколько, то можно напечатать любую из них.

    Описание входных и выходных данных

    В первой строке входных данных задаётся количество чисел n (2 ≤ n ≤ 12 000).

    В каждой из последующих n строк записано одно целое положительное число, не превышающее 10 000.

    В качестве результата программа должна напечатать элементы искомой пары. Если таких пар несколько, можно вывести любую из них. Гарантируется, что хотя бы одна такая пара в последовательности есть.

     

    Пример входных данных:

    6

    60

    140

    61

    100

    300

    59

     

    Пример выходных данных для приведённого выше примера входных данных:

    140 100

     

    Пояснение. Из шести заданных чисел можно составить три пары, сумма элементов которых делится на m  =  120: 60 + 300, 140 + 100 и 61 + 59. Во второй и третьей из этих пар первый элемент больше второго, но во второй паре сумма больше.

    Требуется написать эффективную по времени и памяти программу для решения описанной задачи.

    Программа считается эффективной по времени, если при одновременном увеличении количества элементов последовательности n и параметра m в k раз время работы программы увеличивается не более чем в k раз.

    Программа считается эффективной по памяти, если память, необходимая для хранения всех переменных программы, не превышает 4 килобайта и не увеличивается с ростом n.

    Максимальная оценка за правильную (не содержащую синтаксических ошибок и дающую правильный ответ при любых допустимых входных данных) программу, эффективную по времени и памяти,  — 4 балла. Максимальная оценка за правильную программу, возможно, неэффективную по памяти или время выполнения которой существенно зависит от величины m,  — 3 балла.

    Максимальная оценка за правильную программу, не удовлетворяющую требованиям эффективности,  — 2 балла.

    Вы можете сдать одну программу или две программы решения задачи (например, одна из программ может быть менее эффективна). Если Вы сдадите две программы, то каждая из них будет оцениваться независимо от другой, итоговой станет бо́льшая из двух оценок.

    Перед текстом программы обязательно кратко опишите алгоритм решения. Укажите использованный язык программирования и его версию.

    Ответ

    Миша заполнял таблицу истинности функции (x ∧ ¬y) ∨ (x ≡ z) ∨ ¬w, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

            (x ∧ ¬y) ∨ (x ≡ z) ∨ ¬w
    0 1 1 0 0
    0       0
      1 0 1 0

     

    Определите, какому столбцу таблицы истинности соответствует каждая из переменных w, x, y, z.

    Ответ

    Для кодирования некоторой последовательности, состоящей из букв К, Л, М, Н, П, Р, решили использовать неравномерный двоичный код, удовлетворяющий условию Фано. Для букв К, Л, М, Н использовали соответственно кодовые слова 000, 001, 010, 11. Для двух оставшихся букв  — П и Р  — длины кодовых слов неизвестны. Укажите кратчайшее возможное кодовое слово для буквы П, при котором код будет удовлетворять условию Фано. Если таких кодов несколько, укажите код с наименьшим числовым значением.

    Ответ

    Для хранения произвольного растрового изображения размером 128 × 320 пикселей отведено 40 Кбайт памяти без учёта размера заголовка файла. Для кодирования цвета каждого пикселя используется одинаковое количество бит, коды пикселей записываются в файл один за другим без промежутков. Какое максимальное количество цветов можно использовать в изображении?

    Ответ

    Все 4-⁠буквенные слова, в составе которых могут быть буквы Н, О, Т, К, И, записаны в алфавитном порядке и пронумерованы, начиная с 1.

    Ниже приведено начало списка.

    1.  ИИИИ

    2.  ИИИК

    3.  ИИИН

    4.  ИИИО

    5.  ИИИТ

    6.  ИИКИ

    ...

     

    Под каким номером в списке идёт первое слово, которое начинается с буквы О?

    Ответ

    Запишите подряд без пробелов и разделителей все числа, которые будут выведены на экран при выполнении вызова F(5). Числа должны быть записаны в том же порядке, в котором они выводятся на экран.

    def F(n):
        print(n, end='')
        if n >= 3:
            F(n // 2)
            F(n - 1)

    Ответ

    При регистрации в компьютерной системе каждому пользователю выдаётся идентификатор, состоящий из 15 символов и содержащий только символы из 8-символьного набора: А, В, C, D, Е, F, G, H. В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование идентификаторов, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно идентификатора, для каждого объекта в системе хранятся дополнительные сведения, для чего отведено 24 байт на один объект.

    Определите объём памяти (в байтах), необходимый для хранения сведений о 20 объектах. В ответе запишите только целое число  — количество байт.

    Ответ

    В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая  — к адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес,  — в виде четырёх байтов, причём каждый байт записывается в виде десятичного числа. При этом в маске сначала (в старших разрядах) стоят единицы, а затем с некоторого разряда  — нули. Адрес сети получается в результате применения поразрядной конъюнкции к заданному IP-адресу узла и маске.

    Например, если IP-адрес узла равен 231.32.255.131, а маска равна 255.255.240.0, то адрес сети равен 231.32.240.0.

    Для узла с IP-адресом 111.81.27.224 адрес сети равен 111.81.27.192. Чему равен последний (самый правый) байт маски? Ответ запишите в виде десятичного числа.

    Ответ

    Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 70 идущих подряд цифр 8? В ответе запишите полученную строку.

    НАЧАЛО

        ПОКА нашлось (2222) ИЛИ нашлось (8888)

            ЕСЛИ нашлось (2222)

                ТО заменить (2222, 88)

                ИНАЧЕ заменить (8888, 22)

            КОНЕЦ ЕСЛИ

        КОНЕЦ ПОКА

    КОНЕЦ

    Ответ

    На рисунке представлена схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К, Л, М. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой.

    Сколько существует различных путей из города А в город М, проходящих через город Ж?

    Ответ

    Для какого наименьшего целого неотрицательного числа А выражение

    (x + 2y < A) ∨ (y > x) ∨ (x > 30)

    тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?

    Ответ

    Сколько единиц содержится в двоичной записи значения выражения: 48 + 28 – 8?

    Ответ

    В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И»  — символ «&».

    В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

    Запрос Найдено страниц(в сотнях тысяч)
    Поле 54
    Пшеница 40
    Напряжённость 44
    Поле & Пшеница 30
    Напряжённость & Поле 14
    Напряжённость & Пшеница 0

    Какое количество страниц (в сотнях тысяч) будет найдено по запросу Напряжённость | Поле | Пшеница?

    Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.

    Ответ

    В программе используется одномерный целочисленный массив A с индексами от 0 до 11. Значения элементов равны 20, 19, 17, 41, 23, 12, 24, 16, 4, 13, 6, 15 соответственно, т. е. A[0] = 20, A[1] = 19 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы

    s = 0
    n = 0
    for i in range(12):
        if A[i] <= A[n]:
            s += i
            t = A[i]
            A[i] = A[n]
            A[n] = t

    Ответ

    Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 6, а потом 7.

    x = int(input())
     L = 0
     M = 0
     while x > 0:
        M = M + 1
        if x % 2 == 0:
            L = L + 1
        x = x // 2
    print(L)
    print(M)

    Ответ

    Напишите в ответе число, которое будет выведено в результате выполнения следующего алгоритма.

    def F(x):
        return 2 * (x * x - 100) * (x * x - 100) + 5
    a = -20; b = 20
    M = a; R = F(a)
    for t in range(a, b + 1):
        if (F(t) < R):
            M = t; R = F(t)
    print(M + 27)

    Ответ

    Исполнитель преобразует число на экране.

    У исполнителя есть две команды, которым присвоены номера:

    1.  Прибавить 1

    2.  Умножить на 2

    Первая команда увеличивает число на экране на 1, вторая умножает его на 2. Программа для исполнителя  — это последовательность команд.

    Сколько существует программ, для которых при исходном числе 1 результатом является число 20 и при этом траектория вычислений содержит число 10?

    Траектория вычислений программы  — это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 7 траектория будет состоять из чисел 8, 16, 17.

    Ответ

    Сколько существует различных наборов значений логических переменных x1, x2, ...x8, y1, y2, ...y8, которые удовлетворяют всем перечисленным ниже условиям?

    (¬(x1 ≡ y1)) ≡ (x2 ≡ y2)

    (¬(x2 ≡ y2)) ≡ (x3 ≡ y3)

    …

    (¬(x7 ≡ y7)) ≡ (x8 ≡ y8)

     

    В ответе не нужно перечислять все различные наборы значений переменных x1, x2, ...x8, y1, y2, ...y8, при которых выполнена данная система равенств. В качестве ответа Вам нужно указать количество таких наборов.

    Ответ

    На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран минимальную чётную цифру этого числа. Если в числе нет чётных цифр, требуется на экран вывести «NO». Программист написал программу неправильно.

    N = int(input())
    minDigit = N % 10
    while N > 0:
        digit = N % 10
        if digit % 2 == 0:
            if digit < minDigit:
                minDigit = digit
        N = N // 10
     if minDigit == 0:
        print("NO")
     else:
        print(minDigit)

    Последовательно выполните следующее.

    1.  Напишите, что выведет эта программа при вводе числа 231.

    2.  Приведите пример такого трёхзначного числа, при вводе которого приведённая программа, несмотря на ошибки, выдаёт верный ответ.

    3.  Найдите допущенные программистом ошибки и исправьте их. Исправление ошибки должно затрагивать только строку, в которой находится ошибка. Для каждой ошибки:

    1)  выпишите строку, в которой сделана ошибка;

    2)  укажите, как исправить ошибку, т. е. приведите правильный вариант строки.

    Известно, что в тексте программы можно исправить ровно две строки так, чтобы она стала работать правильно.

    Достаточно указать ошибки и способ их исправления для одного языка программирования.

    Обратите внимание на то, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения.

    Ответ

    Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в три раза. Например, пусть в одной куче 10 камней, а в другой 7 камней; такую позицию в игре будем обозначать (10, 7). Тогда за один ход можно получить любую из четырёх позиций: (11, 7), (30, 7), (10, 8), (10, 21). Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

    Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 68. Победителем считается игрок, сделавший последний ход, т. е. первым получивший такую позицию, при которой в кучах будет 68 или больше камней.

    В начальный момент в первой куче было шесть камней, во второй куче  — S камней; 1 ≤ S ≤ 61.

    Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока – значит, описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. В описание выигрышной стратегии не следует включать ходы играющего по этой стратегии игрока, не являющиеся для него безусловно выигрышными, т. е. не являющиеся выигрышными независимо от игры противника.

     

    Выполните следующие задания.

    Задание 1.

    а)  Укажите все такие значения числа S, при которых Петя может выиграть за один ход.

    б)  Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, когда такая ситуация возможна.

    Задание 2. Укажите такое значение S, при котором у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

    — Петя не может выиграть за один ход;

    — Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

    Для указанного значения S опишите выигрышную стратегию Пети.

    Задание 3. Укажите значение S, при котором одновременно выполняются два условия:

    — у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

    — у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

    Для указанного значения S опишите выигрышную стратегию Вани.

    Постройте дерево всех партий, возможных при этой выигрышной стратегии Вани (в виде рисунка или таблицы).

    В узлах дерева указывайте позиции, на рёбрах рекомендуется указывать ходы. Дерево не должно содержать партии, невозможные при реализации выигрывающим игроком своей выигрышной стратегии. Например, полное дерево игры не является верным ответом на это задание.

    Ответ

    Бесплатно
    Приложение ЕГЭ Тренажёр

    Скачивай мобильное приложение на iPhone или Android и тренируйся в любое время и в любом месте!

    Результаты тренировки
    Решено заданий 0
    Выполнено верно 0
    Выполнено частично верно 0
    Ошибки 0