Новая Школа - онлайн-школа подготовки к ЕГЭ
При поддержке
  • Тренажёр заданий ЕГЭ
  • Информатика
  • Реальные варианты
  • Реальный вариант ЕГЭ 2019 (основная волна)
  • Реальный вариант ЕГЭ 2019 (основная волна) - Информатика

    Сколько существует натуральных чисел x, для которых верно неравенство 110110102 < x < DF16?

    В ответе укажите количество чисел, сами числа писать не нужно.

    Ответ

    На рисунке схема дорог Н-⁠ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).

      П1 П2 П3 П4 П5 П6
    П1     12 6 15 13
    П2           11
    П3 12       9  
    П4 6       7 5
    П5 15   9 7    
    П6 13 11   5    

    Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова протяжённость дороги из пункта Б в пункт В. В ответе запишите целое число  — так, как оно указано в таблице.

    Ответ

    Ниже представлены два фрагмента таблиц из базы данных о жителях микрорайона. Каждая строка таблицы 2 содержит информацию о ребёнке и об одном из его родителей. Информация представлена значением поля ID в соответствующей строке таблицы 1. Определите на основании приведённых данных, у скольких детей на момент их рождения матерям было больше 24 полных лет. При вычислении ответа учитывайте только информацию из приведённых фрагментов таблиц.

    Ответ

    По каналу связи передаются шифрованные сообщения, содержащие только десять букв: А, Б, Е, И, К, Л, Р, С, Т, У; для передачи используется неравномерный двоичный код. Для девяти букв используются кодовые слова.

     

    Буква Кодовое слово
    А 00
    Б 1000
    Е 010
    И 011
    К 1011

     

     
    Буква Кодовое слово
    Л 1001
    Р  
    С 1010
    Т 1101
    У 111

    Укажите кратчайшее кодовое слово для буквы Р, при котором код будет удовлетворять условию Фано. Если таких кодов несколько, укажите код с наименьшим числовым значением.

     

    Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.

    Ответ

    На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

     

    1.  Строится двоичная запись числа N.

    2.  К этой записи дописываются справа ещё два разряда по следующему правилу:

    а)  складываются все цифры двоичной записи числа N, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001;

    б)  над этой записью производятся те же действия  — справа дописывается остаток от деления суммы её цифр на 2.

     

    Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью искомого числа R.

    Укажите минимальное число R, которое превышает число 55 и может являться результатом работы данного алгоритма. В ответе это число запишите в десятичной системе счисления.

    Ответ

    Дан фрагмент электронной таблицы. Из ячейки D2 в ячейку E1 была скопирована формула. При копировании адреса ячеек в формуле автоматически изменились. Каким стало числовое значение формулы в ячейке E1?

     

      A B C D E
    1 1 10 100 1000  
    2 2 20 200 =B2+$C$3 20000
    3 3 30 300 3000 30000
    4 4 40 400 4000 40000

     

    Примечание. знак $ обозначает абсолютную адресацию.

    Ответ

    Запишите число, которое будет напечатано в результате выполнения следующей программы.

    s = 230
    n = 0
    while s > 0:
        s = s − 15
        n = n + 2
    print(n)

    Ответ

    Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно. Опишите на одном из языков программирования алгоритм, который находит количество элементов массива, не меньших 1002 и при этом кратных 3, а затем заменяет каждый такой элемент на число, равное найденному количеству. Гарантируется, что хотя бы один такой элемент в массиве есть. В качестве результата необходимо вывести изменённый массив, каждый элемент выводится с новой строчки.

     

    Например, для исходного массива из шести элементов:

    4

    1104

    74

    1005

    6

    1006

    программа должна вывести следующий массив:

    4

    2

    74

    2

    6

    1006

    # допускается также
    # использовать две
    # целочисленные переменные j и k
    a = []
    n = 30
    for i in range(0, n):
        a.append(int(input()))
    …

    В качестве ответа Вам необходимо привести фрагмент программы, который должен находиться на месте многоточия. Вы можете записать решение также на другом языке программирования (укажите название и используемую версию языка программирования, например Free Pascal 2.6). В этом случае Вы должны использовать те же самые исходные данные и переменные, какие были предложены в условии (например, в образце, записанном на Алгоритмическом языке).

    Ответ

    На вход программы поступает последовательность из N целых положительных чисел, все числа в последовательности различны. Рассматриваются все пары различных элементов последовательности (элементы пары могут быть расположены в последовательности не рядом, порядок элементов в паре неважен). Необходимо определить количество пар, для которых произведение элементов делится без остатка на 10.

    Описание входных и выходных данных.

    В первой строке входных данных задаётся количество чисел N (1 ≤ N ≤ 1000). В каждой из последующих N строк записано одно целое положительное число, не превышающее 10 000.

    В качестве результата программа должна напечатать одно число: количество пар, в которых произведение элементов кратно 10.

    Пример входных данных:

    4

    2

    6

    5

    15

    Пример выходных данных для приведённого выше примера входных данных:

    4

     

    Пояснение. Из четырёх заданных чисел можно составить 6 попарных произведений: 2 · 6, 2 · 5, 2 · 15, 6 · 5, 6 · 15, 5 · 15 (результаты: 12, 10, 30, 30, 90, 75). Из них на 10 без остатка делятся 4 произведения (2 · 5  =  10; 2 · 15  =  30; 6 · 5  =  30; 6 · 15  =  90).

    Требуется написать эффективную по времени и памяти программу для решения описанной задачи.

    Программа считается эффективной по времени, если при увеличении количества исходных чисел N в k раз время работы программы увеличивается не более чем в k раз.

    Программа считается эффективной по памяти, если память, необходимая для хранения всех переменных программы, не превышает 1 килобайта и не увеличивается с ростом N.

    Максимальная оценка за правильную (не содержащую синтаксических ошибок и дающую правильный ответ при любых допустимых входных данных) программу, эффективную по времени и памяти,  — 4 балла.

    Максимальная оценка за правильную программу, эффективную только по времени  — 3 балла.

    Максимальная оценка за правильную программу, не удовлетворяющую требованиям эффективности,  — 2 балла.

    Вы можете сдать одну программу или две программы решения задачи (например, одна из программ может быть менее эффективна). Если Вы сдадите две программы, то каждая из них будет оцениваться независимо от другой, итоговой станет бо́льшая из двух оценок.

    Перед текстом программы обязательно кратко опишите алгоритм решения. Укажите использованный язык программирования и его версию.

    Ответ

    Миша заполнял таблицу истинности функции (x ∧ y) ∨ (y ≡ z) ∨ w, но успел заполнить лишь фрагмент из трёх различных её строк, даже не указав, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

            (x ∧ y) ∨ (y ≡ z) ∨ w
      1 0 0 0
    0   1   0
    0 1   1 0

     

    Определите, какому столбцу таблицы соответствует каждая из переменных w, x, y, z.

    Ответ

    Какой минимальный объём памяти (в Кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 640 на 320 пикселей при условии, что в изображении могут использоваться 64 различных цвета? В ответе запишите только целое число, единицу измерения писать не нужно.

    Ответ

    Вася составляет 6-⁠буквенные слова из букв К, О, Т. Причем буква К используется в каждом слове ровно 1 раз. Остальные буквы могут быть использованы любое количество раз, в том числе совсем отсутствовать. Сколько слов может составить Вася? Словом называется любая буквенная комбинация, не обязательно осмысленное слово русского языка.

    Ответ

    Запишите подряд без пробелов и разделителей все числа, которые будут выведены на экран при выполнении вызова F(3). Числа должны быть записаны в том же порядке, в котором они выводятся на экран.

    def F(n):
        print(n)
        if n >= 2:
            F(n – 2)
            F(n – 1)
            F(n – 2)
     

    Ответ

    В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая – к адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес, – в виде четырёх байтов, причём каждый байт записывается в виде десятичного числа. При этом в маске сначала (в старших разрядах) стоят единицы, а затем с некоторого разряда  — нули. Адрес сети получается в результате применения поразрядной конъюнкции к заданному IP-адресу узла и маске.

    Например, если IP-адрес узла равен 231.32.255.131, а маска равна 255.255.240.0, то адрес сети равен 231.32.240.0.

     

    Для узла с IP-адресом 111.81.176.27 адрес сети равен 111.81.160.0. Чему равен третий слева байт маски? Ответ запишите в виде десятичного числа.

    Ответ

    При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 10 символов. В качестве символов используют прописные буквы латинского алфавита, т. е. 26 различных символов. В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего отведено 15 байт на одного пользователя.

    Определите объём памяти (в байтах), необходимый для хранения сведений о 50 пользователях. В ответе запишите только целое число – количество байт.

    Ответ

    Чертёжнику был дан для исполнения следующий алгоритм (число повторений и величины смещения в первой из повторяемых команд неизвестны):

     

    НАЧАЛО

    сместиться на (–2, 1)

    ПОВТОРИ … РАЗ

        сместиться на (…, …)

        сместиться на (5, −7)

    КОНЕЦ ПОВТОРИ

    сместиться на (−34, −28)

    КОНЕЦ

     

    В результате выполнения этого алгоритма Чертёжник возвращается в исходную точку. Какое наибольшее число повторений могло быть указано в конструкции «ПОВТОРИ … РАЗ»?

    Ответ

    На рисунке  — схема дорог, связывающих пункты А, Б, В, Г, Д, Е, К, Л, М.

    Сколько существует различных путей, ведущих из города А в город М, проходящих через город В?

    Ответ

    Для какого наименьшего целого неотрицательного числа A выражение

    (y + 2x < A) ∨ (x > 15) ∨ (y > 30)

    тождественно истинно при всех вещественных значениях x и y?

    Ответ

    Сколько единиц содержится в двоичной записи значения выражения: 416 + 236 − 8?

    Ответ

    В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для обозначения логической операции «И»  — символ «&».

    В таблице приведены запросы и количество найденных по ним страниц некоторого сегмента сети Интернет.

    Запрос Найдено страниц

    (в сотнях тысяч)

    Горло 35
    Корабль 30
    Нос 40
    Горло | Корабль| Нос 70
    Горло & Нос 10
    Горло & Корабль 0

    Какое количество страниц (в сотнях тысяч) будет найдено по запросу

    Корабль & Нос?

    Считается, что все запросы выполнялись практически одновременно, так что набор страниц, содержащих все искомые слова, не изменялся за время выполнения запросов.

    Ответ

    В программе используется одномерный целочисленный массив A с индексами от 0 до 11. Значения элементов равны 5, 8, 7, 11, 10, 12, 9, 6, 4, 13, 3, 15 соответственно, т. е. A[0] = 5, A[1] = 8 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы

    n = 0
    s = 0
    for i in range(1, 12):
        if A[i] > A[n]:
            s = s + 1
            t = A[i]
            A[i] = A[n]
            A[n] = t

    Ответ

    Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 5, а потом 6.

    x = int(input())
     L = 0
     M = 0
    while x > 0:
        M = M + 1
        if x % 2 != 0:
            L = L + 1
        x = x // 2
    print(L)
    print(M)
     

    Ответ

    Напишите в ответе число, равное количеству различных значений входной переменной k, при которых приведённая ниже программа выводит тот же ответ, что и при входном значении k  =  12. Значение k  =  12 также включается в подсчёт различных значений k.

    def f(n):
        return n*n*n
     
    k = int(input())
    i = 1
    while f(i) < k:
        i = i + 1
    if f(i)–k <= k–f(i−1):
        print(i)
    else:
        print(i−1)
     

    Ответ

    Исполнитель преобразует число на экране.

    У исполнителя есть две команды, которым присвоены номера:

    1.  Прибавить 1

    2.  Умножить на 2

    Первая команда увеличивает число на экране на 1, вторая умножает его на 2. Программа для исполнителя – это последовательность команд.

    Сколько существует программ, для которых при исходном числе 2 результатом является число 29 и при этом траектория вычислений содержит число 14?

    Траектория вычислений программы  — это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 7 траектория будет состоять из чисел 8, 16, 17.

    Ответ

    Сколько существует различных наборов значений логических переменных x1, x2, ..., x8, y1, y2, ..., y8, которые удовлетворяют всем перечисленным ниже условиям?

     

    (x1 ∧ y1) ≡ (¬x2 ∨ ¬y2)

    (x2 ∧ y2) ≡ (¬x3 ∨ ¬y3)

    ...

    (x7 ∧ y7) ≡ (¬x8 ∨ ¬y8)

     

    В ответе не нужно перечислять все различные наборы значений переменных x1, x2, ..., x8, y1, y2, ..., y8, при которых выполнена данная система равенств. В качестве ответа Вам нужно указать количество таких наборов.

    Ответ

    На обработку поступает последовательность из четырёх неотрицательных целых чисел (некоторые числа могут быть одинаковыми). Нужно написать программу, которая выводит на экран количество всех чисел исходной последовательности, которые делятся без остатка на 10, и сумму таких чисел. Если в последовательности нет чисел, которые делятся без остатка на 10, то на экран нужно вывести «NO». Известно, что вводимые числа не превышают 1000. Программист написал программу неправильно.

    n = 4
    count = 0
    sum = 0
    for i in range(1, n+1):
        x = int(input())
        if x % 10 == 0:
            count = count + 1
            sum = x
    if sum > 0:
        print(count)
        print(sum)
    else:
        print("NO")

    Последовательно выполните следующее.

    1.  Напишите, что выведет эта программа при вводе последовательности: 20, 25, 40, 45.

    2.  Приведите пример последовательности, в которой есть хотя бы одно число, делящееся на без остатка 10, при вводе которой, несмотря на ошибки, программа печатает правильный ответ.

    3.  Найдите все ошибки в этой программе (их может быть одна или несколько). Известно, что каждая ошибка затрагивает только одну строку и может быть исправлена без изменения других строк. Для каждой ошибки:

    1)  выпишите строку, в которой сделана ошибка;

    2)  укажите, как исправить ошибку, т. е. приведите правильный вариант строки.

     

    Достаточно указать ошибки и способ их исправления для одного языка программирования.

    Обратите внимание на то, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.

    Ответ

    Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один камень либо увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 16 или 30 камней. У каждого игрока, чтобы делатьходы, есть неограниченное количество камней.

    Игра завершается в тот момент, когда количество камней в куче становится не менее 26.

    Победителем считается игрок, сделавший последний ход, т. е. первым получивший кучу, в которой будет 26 или больше камней. В начальный момент в куче было S камней, 1 ≤ S ≤ 25.

    Будем говорить, что игрок имеет выигрышную стратегию, если он может

    выиграть при любых ходах противника. Описать стратегию игрока  — значит, описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. В описание выигрышной стратегии не следует включать ходы играющего по этой стратегии игрока, не являющиеся для него безусловно выигрышными, т. е. не являющиеся выигрышными независимо от игры противника.

    Выполните следующие задания. Во всех случаях обосновывайте свой ответ.

     

    Задание 1

    а)  Укажите все такие значения числа S, при которых Петя может выиграть за один ход.

    б)  Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом. Опишите выигрышную стратегию Вани.

     

    Задание 2

    Укажите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполнены два условия:

    — Петя не может выиграть за один ход;

    — Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

    Для каждого указанного значения S опишите выигрышную стратегию Пети.

     

    Задание 3

    Укажите значение S, при котором:

    — у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

    — у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

    Для указанного значения S опишите выигрышную стратегию Вани. Постройте дерево всех партий, возможных при этой выигрышной стратегии Вани (в виде рисунка или таблицы).

    В узлах дерева указывайте позиции, на рёбрах рекомендуется указывать ходы. Дерево не должно содержать партии, невозможные при реализации выигрывающим игроком своей выигрышной стратегии. Например, полное дерево игры не является верным ответом на это задание.

    Ответ

    Бесплатно
    Приложение ЕГЭ Тренажёр

    Скачивай мобильное приложение на iPhone или Android и тренируйся в любое время и в любом месте!

    Результаты тренировки
    Решено заданий 0
    Выполнено верно 0
    Выполнено частично верно 0
    Ошибки 0